hdu 2012 素数判定

http://acm.hdu.edu.cn/showproblem.php?pid=2012

题目大意

对于表达式n^2+n+41,当n在(x,y)范围内取整数值时(包括x,y)(-39<=x<y<=50),判定该表达式的值是否都为素数。

Sample Input

1 0

0 0

Sample Output

OK

方法与总结

  • 水题,注意素数的判断

代码

#include<iostream>
#include<cmath>
using namespace std;

bool isPri(int x)
{
    int i;
    float k=sqrt(x);
    for(i=2;i<=k;i++)
    if(x%i==0)
    return 0;
    return 1;
}

int main()
{
    int x,y;
    while(cin>>x>>y && (x!=0 || y!=0))
    {
        int i;
        bool flag=1;
        for(int i=x;i<=y;i++)
        if(!isPri(i*i+i+41))
        {
            flag=0;
            break;
        }
        if(flag)
        cout<<"OK"<<endl;
        else
        cout<<"Sorry"<<endl;
    }
    return 0;
}
/* bottom:40px 距浏览器底部距离 right:40px 距浏览器右边距离 */