http://acm.hdu.edu.cn/showproblem.php?pid=2017
题目大意
对于给定的一个字符串,统计其中数字字符出现的次数。
Sample Input
2
asdf111111111asdfasdfasdf
Sample Output
6
9
方法与总结
- 水题
代码
#include<iostream>
#include<string>
using namespace std;
bool isnum(char s)
{
if(s>='0' && s<='9')
return 1;
else
return 0;
}
int main()
{
int n,count;
string str;
cin>>n;
while(n--)
{
count=0;
cin>>str;
for(int i=0;i<str.length();i++)
{
if(isnum(str[i]))
count++;
}
cout<<count<<endl;
}
return 0;
}